GNU ELPA - tramp

tramp

Description
Transparent Remote Access, Multiple Protocol
Latest
tramp-2.6.2.1.tar (.sig), 2024-Jan-30, 1.88 MiB
Maintainer
Michael Albinus <michael.albinus@gmx.de>
Website
https://www.gnu.org/software/tramp/
Browse ELPA's repository
CGit or Gitweb
Badge
Manual
tramp

To install this package from Emacs, use package-install or list-packages.

Full description

Installing Tramp via GNU ELPA
*****************************

Tramp stands for “Transparent Remote (file) Access, Multiple Protocol”.
This package provides remote file editing, similar to Ange-FTP.

The difference is that Ange-FTP uses FTP to transfer files between the
local and the remote host, whereas Tramp uses a combination of ‘rsh’ and
‘rcp’ or other work-alike programs, such as ‘ssh’/‘scp’.

A remote file name has always the syntax

     /method:user%domain@host#port:/path/to/file

Most of the parts are optional, read the manual
<https://www.gnu.org/software/tramp/> for details.

Tramp must be compiled for the Emacs version you are running.  If you
experience compatibility error messages for the Tramp package, or if you
use another major Emacs version than the version Tramp has been
installed with, you must recompile the package:

Emacs 29 or newer
-----------------

   • Recompile the Tramp package

          M-x package-recompile RET tramp

Emacs 28 or older
-----------------

   • Remove all byte-compiled Tramp files

          $ rm -f ~/.emacs.d/elpa/tramp-2.6.2.1/tramp*.elc

   • Start Emacs with Tramp’s source files

          $ emacs -L ~/.emacs.d/elpa/tramp-2.6.2.1 -l tramp

     This should not give you the error.

   • Recompile the Tramp package *with this running Emacs instance*

          M-x tramp-recompile-elpa

     Afterwards, you must restart Emacs.

Mitigation of a bug in Emacs 29.1
---------------------------------

Due to a bug in Emacs 29.1, you must apply the following change prior
installation or upgrading Tramp 2.6.2.1 from GNU ELPA:

     (when (string-equal emacs-version "29.1")
       (with-current-buffer
           (url-retrieve-synchronously
            "https://git.savannah.gnu.org/cgit/emacs.git/plain/lisp/emacs-lisp/loaddefs-gen.el?h=emacs-29")
         (goto-char (point-min))
         (while (looking-at "^.+$") (forward-line))
         (eval-region (point) (point-max))))

Old versions

tramp-2.6.2.0.tar.lz2023-Dec-30 296 KiB
tramp-2.6.1.5.tar.lz2023-Nov-29 295 KiB
tramp-2.6.1.4.tar.lz2023-Oct-30 295 KiB
tramp-2.6.1.3.tar.lz2023-Sep-29 295 KiB
tramp-2.6.1.2.tar.lz2023-Aug-30 295 KiB
tramp-2.6.1.1.1.tar.lz2023-Aug-07 295 KiB
tramp-2.6.1.tar.lz2023-Jun-29 294 KiB
tramp-2.6.0.5.tar.lz2023-May-30 294 KiB
tramp-2.6.0.1.tar.lz2023-Jan-30 291 KiB
tramp-2.6.0.tar.lz2022-Dec-30 291 KiB
tramp-2.5.4.tar.lz2022-Nov-29 275 KiB
tramp-2.5.3.3.tar.lz2022-Sep-29 274 KiB
tramp-2.5.3.tar.lz2022-Jun-29 274 KiB
tramp-2.5.2.5.tar.lz2022-May-30 274 KiB
tramp-2.5.2.tar.lz2021-Dec-30 271 KiB
tramp-2.5.1.5.tar.lz2021-Nov-29 272 KiB
tramp-2.5.0.5.tar.lz2021-May-30 265 KiB
tramp-2.4.4.4.tar.lz2020-Nov-29 222 KiB
tramp-2.4.3.5.tar.lz2020-May-29 243 KiB
tramp-2.4.2.5.tar.lz2019-Nov-30 240 KiB